2003 CL600 with P0120, ESP, Distronic errors, fixed by mb sdconnect

Problem description:

2003 CL600 throwing P0120 (throttle position sensor); dash display reads ESP and Distronic errors (white, not red); check engine light is intermittent, and car is in limp mode. Have replaced throttle pedal assembly, passenger coil pack (found a cracked coil), and plugs. Found oil around some of the plugs, and at 39K mi they looked like they had 139K miles on them…ugly. Also spotted a vac hose with a hole, and had a cracked nipple on the air sensor closest to the throttle body.

Car also idles rough occasionally…have checked fuses and relays for all the above-named suspects…even going under rear seat on driver’s side. I’m confused because the idle makes me think the issue is mechanical in nature…but the car behaves differently when my OBDII scanner is connected.

 

Tool to use and how to do:

you have to get a Xentry DAS
without that you will spend money scanning with these idiots at MB dealer garage
and probably never find

just get a MB SD C4 sdconnect (C5 is not confirmed as real yet)
from any Chinese shop, recommend you http://www.eobdtool.co.uk with a nice salesperson and after-sales service.

get yourself a dell D630
go to specialized software sites like MHH AUTO, CarTechnoloGY ect
then download a all ready Acronis image of a Xentry 2015 version or 2014 or what you want
clone the image to your laptop’s SSD
there you go
all for free
or ready Dell D630 drive with your C4 package
or a whole ready D630 laptop with your package

eobdtool.co.uk